Department of Mathematics and Computer Science

www.univ-soukahras.dz/en/dept/mi

Module: Electronique et composants des systèmes

  1. Information
  2. Questions

initiation à l'algorithmique

-3 votes

Asked on 15:52, Thursday 24 Nov 2016 By dhoha bouhama (6 points)
In Electronique et composants des systèmes


answers (10)




Answer (1)

0 votes

En peut fair une boucle 

Algorithme   somdiv ;

Var i,n,s,d: entière ;

Début

Lire( n);

Pour i:=1a n faire

d:=1 div i;

i:=i+1;

S:=1+d;

Fin pour;

Écrire(s);

Fin.

 

Answered on 21:32, Friday 2 Dec 2016 by ferdous fouathia (12 points)
In Electronique et composants des systèmes



Answer (2)

0 votes

Dans la réponse  de Fouathia il faudra faire le test sur N stritement positif

initialiser S et S n'est pas entier

d:=1/i c'est une division réelle pas entière

s:=s+d

Answered on 21:22, Saturday 3 Dec 2016 by Nadia BENATI
In Electronique et composants des systèmes



Answer (3)

0 votes

Vraiment s est réel mais je déclare que n est entière 

Answered on 21:01, Monday 5 Dec 2016 by ferdous fouathia (12 points)
In Electronique et composants des systèmes



Answer (4)

0 votes

En peut fair une boucle 

Algorithme   somdiv ;

Var i,n,s,d: entière ;

Début

Lire( n);

Pour i:=1a n faire

d:=1 / i;

i:=i+1;

S:=s+d;

Fin pour;

Écrire(s);

Fin.

Answered on 10:38, Friday 17 Nov 2017 by نسرين ولهي (106 points)
In Electronique et composants des systèmes



Answer (5)

0 votes

algorithme som;

var i , n,s, d : entiere ;

debut 

ecrire( ' donnez n') ;

lire(n);

pour i := 1 a n faire 

d := 1/ i ;

i := i +1 ; 

s := s+d ; 

fin;

ecrire( ' la somme est' , s ) ;

fin .

Answered on 10:45, Friday 17 Nov 2017 by Amani Haraoubia (47 points)
In Electronique et composants des systèmes



Answer (6)

0 votes

algorithme som;

var i , n,s, d : entiere ;

debut 

ecrire( ' donnez n') ;

lire(n);

pour i := 1 a n faire 

d := 1/ i ;

i := i +1 ; 

s := s+d ; 

fin;

ecrire( ' la somme est' , s ) ;

fin .

Answered on 14:55, Friday 17 Nov 2017 by oussama baha eddine farhi (257 points)
In Electronique et composants des systèmes



Answer (7)

0 votes

Algorithme suit;

VAR s,n,i:entier;

Debut

Lire(n);

Si n>0 alors

S:=1;

Pour i:=1 a n faire

S:=(s+1/i);

Ftq

fsi;

Ecrire(s);

Fin.

 

Answered on 20:38, Friday 17 Nov 2017 by abderrahmane brinis (136 points)
In Electronique et composants des systèmes



Answer (8)

0 votes

algorithme suite;

var s,n,i:entier;

debut

lire(n);

si n>0 alors

s:=1;

pour i:=1 a n faire

s:=(s+1/i);

ftq

fsi;

ecrire(s);

fin.

Answered on 14:04, Saturday 18 Nov 2017 by Haifa Benlassowd (76 points)
In Electronique et composants des systèmes



Answer (9)

0 votes

Algorithme suite ;

Var n,s,i:entier ;

Début 

Lire (n);

Si n>0 alors 

Si:=1;

Pour i:=1 a n fait

S:=(s+1/i);

Ftq

Fsi;

Écrire (s);

Fin.

Answered on 18:40, Saturday 18 Nov 2017 by Marwa GHODBANE (54 points)
In Electronique et composants des systèmes



Answer (10)

0 votes

En peut faire une boucle 

Algorithme   somdiv ;

Var i,n,s,d: entière ;

Début

Lire( n);

Pour i:=1a n faire

d:=1 / i;

i:=i+1;

S:=s+d;

Fin pour;

Écrire(s);

Fin.

Answered on 13:19, Friday 1 Dec 2017 by sara younsi (127 points)
In Electronique et composants des systèmes



Do you have an answer ?