قسم الرياضيات و الإعلام الإلي

www.univ-soukahras.dz/ar/dept/mi

المقياس: Electronique et composants des systèmes

  1. معلومات
  2. الأسئلة
  3. التعليم عن بعد

initiation à l'algorithmique

-3 votes

نشر على 15:52, الخميس 24 نوف 2016 By dhoha bouhama (6 points)
In Electronique et composants des systèmes


أجوبة (10)




جواب (1)

0 votes

En peut fair une boucle 

Algorithme   somdiv ;

Var i,n,s,d: entière ;

Début

Lire( n);

Pour i:=1a n faire

d:=1 div i;

i:=i+1;

S:=1+d;

Fin pour;

Écrire(s);

Fin.

 

نشر على 21:32, الجمعة 2 ديس 2016 by ferdous fouathia (12 points)
In Electronique et composants des systèmes



جواب (2)

0 votes

Dans la réponse  de Fouathia il faudra faire le test sur N stritement positif

initialiser S et S n'est pas entier

d:=1/i c'est une division réelle pas entière

s:=s+d

نشر على 21:22, السبت 3 ديس 2016 by Nadia BENATI
In Electronique et composants des systèmes



جواب (3)

0 votes

Vraiment s est réel mais je déclare que n est entière 

نشر على 21:01, الاثنين 5 ديس 2016 by ferdous fouathia (12 points)
In Electronique et composants des systèmes



جواب (4)

0 votes

En peut fair une boucle 

Algorithme   somdiv ;

Var i,n,s,d: entière ;

Début

Lire( n);

Pour i:=1a n faire

d:=1 / i;

i:=i+1;

S:=s+d;

Fin pour;

Écrire(s);

Fin.

نشر على 10:38, الجمعة 17 نوف 2017 by نسرين ولهي (106 points)
In Electronique et composants des systèmes



جواب (5)

0 votes

algorithme som;

var i , n,s, d : entiere ;

debut 

ecrire( ' donnez n') ;

lire(n);

pour i := 1 a n faire 

d := 1/ i ;

i := i +1 ; 

s := s+d ; 

fin;

ecrire( ' la somme est' , s ) ;

fin .

نشر على 10:45, الجمعة 17 نوف 2017 by Amani Haraoubia (47 points)
In Electronique et composants des systèmes



جواب (6)

0 votes

algorithme som;

var i , n,s, d : entiere ;

debut 

ecrire( ' donnez n') ;

lire(n);

pour i := 1 a n faire 

d := 1/ i ;

i := i +1 ; 

s := s+d ; 

fin;

ecrire( ' la somme est' , s ) ;

fin .

نشر على 14:55, الجمعة 17 نوف 2017 by oussama baha eddine farhi (257 points)
In Electronique et composants des systèmes



جواب (7)

0 votes

Algorithme suit;

VAR s,n,i:entier;

Debut

Lire(n);

Si n>0 alors

S:=1;

Pour i:=1 a n faire

S:=(s+1/i);

Ftq

fsi;

Ecrire(s);

Fin.

 

نشر على 20:38, الجمعة 17 نوف 2017 by abderrahmane brinis (136 points)
In Electronique et composants des systèmes



جواب (8)

0 votes

algorithme suite;

var s,n,i:entier;

debut

lire(n);

si n>0 alors

s:=1;

pour i:=1 a n faire

s:=(s+1/i);

ftq

fsi;

ecrire(s);

fin.

نشر على 14:04, السبت 18 نوف 2017 by Haifa Benlassowd (76 points)
In Electronique et composants des systèmes



جواب (9)

0 votes

Algorithme suite ;

Var n,s,i:entier ;

Début 

Lire (n);

Si n>0 alors 

Si:=1;

Pour i:=1 a n fait

S:=(s+1/i);

Ftq

Fsi;

Écrire (s);

Fin.

نشر على 18:40, السبت 18 نوف 2017 by Marwa GHODBANE (54 points)
In Electronique et composants des systèmes



جواب (10)

0 votes

En peut faire une boucle 

Algorithme   somdiv ;

Var i,n,s,d: entière ;

Début

Lire( n);

Pour i:=1a n faire

d:=1 / i;

i:=i+1;

S:=s+d;

Fin pour;

Écrire(s);

Fin.

نشر على 13:19, الجمعة 1 ديس 2017 by sara younsi (127 points)
In Electronique et composants des systèmes



هل لديك جواب ?